Excel De Büyükten Küçüğe Sıralama?

  1. KısayolKısayol reportŞikayet pmÖzel Mesaj
    Sigortacı
    DJ_Alper
    DJ_Alper's avatar
    Bilgi/Destek Madalyası
    Kayıt Tarihi: 03/Ocak/2006
    Erkek

    şimdi sayısal loto için birşeyler yapıyorum

    a 1

    b 2

    c 3

    .....

    diye gidiyor şimdi bunları büyükten küçüğe sıralayacağım ama a dan z ye sıralamayı kullanmayacağım ben veri girdiğim an otomatik sıralayacak

    her sefer
     a dan z ye sıralamayı kullanmayacağım bunu nasıl yaparık


    Youtube Kanalıma Abone olan herkese Mesir macunu göndereceğim :) >>> http://bit.ly/2FH1kln . her hakkım saklıdır®™ Sorularınızı cilginsigortaci@gmail.com a yazabilirsiniz cevaplar facebook sayfasında >>> facebook.com/cilginsigortaci █║▌│█│║▌║││█║▌║▌║
  2. KısayolKısayol reportŞikayet pmÖzel Mesaj
    2021 Talihlisi
    joe_black
    joe_black's avatar
    Kayıt Tarihi: 04/Ocak/2006
    Erkek

    bi kere ayarla ne istiyosan. ondan sonra c/p. düz mantık :|

    direkt bu geldi aklıma bi deneyelim


    Sefih ve cahil bir kimse konuşunca ona cevap verme. Sükut, ona cevap vermekten daha hayırlıdır.
  3. KısayolKısayol reportŞikayet pmÖzel Mesaj
    Çömez
    underzero
    underzero's avatar
    Üstün Hizmet Madalyası
    Kayıt Tarihi: 20/Ocak/2003
    Erkek

    mutlaka verileri girdikten sonra siralarsin senin icin daha kolay olur.

    diger turlu macro yazman gerekiyor biraz kasar

     


    pist bak bi ! - Ban Golu Canavari
  4. KısayolKısayol reportŞikayet pmÖzel Mesaj
    Sigortacı
    DJ_Alper
    DJ_Alper's avatar
    Bilgi/Destek Madalyası
    Kayıt Tarihi: 03/Ocak/2006
    Erkek
    underzero bunu yazdı

    mutlaka verileri girdikten sonra siralarsin senin icin daha kolay olur.

    diger turlu macro yazman gerekiyor biraz kasar

     

    anladım şimdi under seni yaklamışken =EĞERSAY(A1:F100;"5") dedik 5 rakamından kaçtane var bana say dedim ama ben demek istiyorumki x hücresinden kaçtane var  bana say yani x hücresinin içindeki rakamdan

    yada

    =EĞERSAY(A1:F100;"5")

    =EĞERSAY(A1:F100;"6")

    bunları seçip şektiğim zaman 6-7-8-9 diye gitmiyor bunları nasıl yaparım yoksa 49 tane tek tek gireceğim :D

    son 5 yılın sonuçlarını girip hangi sayıdan kaçtan çıktığını hesaplatacam :D


    Youtube Kanalıma Abone olan herkese Mesir macunu göndereceğim :) >>> http://bit.ly/2FH1kln . her hakkım saklıdır®™ Sorularınızı cilginsigortaci@gmail.com a yazabilirsiniz cevaplar facebook sayfasında >>> facebook.com/cilginsigortaci █║▌│█│║▌║││█║▌║▌║
  5. KısayolKısayol reportŞikayet pmÖzel Mesaj
    _PesimisT_
    _PesimisT_'s avatar
    Kayıt Tarihi: 27/Nisan/2008
    Erkek

    Hocam en son soru için... Sayfanın görünmeyen bir kısmında sırasıyla sayıları yaz 1.2.3.4.....49 gibi mesela m1 hücresinden aşağı doğru yazdın varsayıyorum... Sonra formül şu şekilde olur...

     

    =EĞERSAY($A$1:$F$99;M1)

    =EĞERSAY($A$1:$F$99;M2)

     

    Çekersen aşağıya doğru devam eder... Kolay gelsin...


    Bu dahil; tüm genellemeler yanlıştır! Yolcu; Kendi Yolunda.... Şükür biz Allahtan başka sahibi olmayanlarız!
  6. KısayolKısayol reportŞikayet pmÖzel Mesaj
    Çömez
    underzero
    underzero's avatar
    Üstün Hizmet Madalyası
    Kayıt Tarihi: 20/Ocak/2003
    Erkek

    B1 e asagidakini gir

    =EĞERSAY(A2:F100;A1)

     

    a1 e ne yazarsan a2 ile f100 arasinda a1 deki rakamlari arattirir


    pist bak bi ! - Ban Golu Canavari
  7. KısayolKısayol reportŞikayet pmÖzel Mesaj
    Çömez
    underzero
    underzero's avatar
    Üstün Hizmet Madalyası
    Kayıt Tarihi: 20/Ocak/2003
    Erkek

    hatta

    excel 2007 de A2:F100 secip menuden conditional formatting a tiklayip, equal to ya tiklayip oraya a1 yazip enterlarsan

    a1 de yazili olan rakami harfi gordugu yerleri renklendirir gorselligi arttirir


    pist bak bi ! - Ban Golu Canavari
  8. KısayolKısayol reportŞikayet pmÖzel Mesaj
    LynXMaSTeR
    LynXMaSTeR's avatar
    Kayıt Tarihi: 19/Temmuz/2003
    Erkek
     

    hocam makro yazmayı biliyorsan aşağıda yazdığım işini görür sanırım. Excel açıkken F11 tuşun bastığında kod yazma kısmı (visualbasic) açılıyor.

     

    A sütunundaki bir değişiklikte sıralama yapar ve aynı satırı bulmaya çalışır.


    Private Sub Worksheet_Change(ByVal Target As Range)
    On Error GoTo Son
    Dim Sat As Long
    Dim Kolon As Integer
    Dim Deger As String
    Dim c As Range
    If Intersect(Target, [A:A]) Is Nothing Then Exit Sub
    If Target.Row < 4 Then Exit Sub
    Kolon = [IV3].End(1).Column
    Deger = Target.Value
    Sat = [A65536].End(3).Row
    Range(Cells(4, "A"), Cells(Sat, Kolon)).Sort Key1:=Cells(4, "A")
    Set c = Range("A4:A" & Sat).Find(Deger)
    Range("B" & c.Row).Select
    Son:
    End Sub

    LynXMaSTeR tarafından 22/Oca/13 01:12 tarihinde düzenlenmiştir

    goo.gl/qBNZmW
  9. KısayolKısayol reportŞikayet pmÖzel Mesaj
    Sigortacı
    DJ_Alper
    DJ_Alper's avatar
    Bilgi/Destek Madalyası
    Kayıt Tarihi: 03/Ocak/2006
    Erkek
    underzero bunu yazdı

    B1 e asagidakini gir

    =EĞERSAY(A2:F100;A1)

     

    a1 e ne yazarsan a2 ile f100 arasinda a1 deki rakamlari arattirir

    onu denediydim olmadı :D

     

    @herkese teşekkürler makro kasalım bi


    Youtube Kanalıma Abone olan herkese Mesir macunu göndereceğim :) >>> http://bit.ly/2FH1kln . her hakkım saklıdır®™ Sorularınızı cilginsigortaci@gmail.com a yazabilirsiniz cevaplar facebook sayfasında >>> facebook.com/cilginsigortaci █║▌│█│║▌║││█║▌║▌║
  10. KısayolKısayol reportŞikayet pmÖzel Mesaj
    LynXMaSTeR
    LynXMaSTeR's avatar
    Kayıt Tarihi: 19/Temmuz/2003
    Erkek

    makro candır. buton bile yapabilirsin makro ile bastığında düzenler, basmadıkça karışık kalır, isme göre sayıya göre sıralatabilirsin, bir çok değişik versiyonunu yapabiirsin.


    goo.gl/qBNZmW
  11. KısayolKısayol reportŞikayet pmÖzel Mesaj
    Mycity
    Mycity's avatar
    Banlanmış Üye
    Kayıt Tarihi: 01/Şubat/2011
    Erkek

    Büyüksün google amca

    bknz : http://office.microsoft.com/tr-tr/excel-help/HP010073947.aspx

    Enter tuşu ile geçiş sorun yaratır bi tane buton atarsın butona basınca sıralar.
    
    Bu a1 hücresine girdiğin verilerin rakamsal değerine göre küçükten büyüğe sıralama yapar.
    
    Kod:
    
    Sub siralama()
    '
    ' siralama Makro
    ' Makro TrueLove tarafından 10.07.2006 tarihinde kaydedildi.
    '
    
    '
        Columns("A:A").Select
        Selection.Sort Key1:=Range("A1"), Order1:=xlAscending, Header:=xlGuess, _
            OrderCustom:=1, MatchCase:=False, Orientation:=xlTopToBottom, _
            DataOption1:=xlSortNormal
    End Sub
    
    
    Mycity tarafından 22/Oca/13 18:55 tarihinde düzenlenmiştir

    Bazıları sadece konuşur bazıları ise hayalleri ile dünya'ya yön verir.. Mycity
Toplam Hit: 2822 Toplam Mesaj: 11